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Preface
INTRODUCTION 
This chapter contains general information that will be useful to know before using the 
Chapter Name. Items discussed in this chapter include:
• Document Layout
• Conventions Used in this Guide
• Warranty Registration
• Recommended Reading
• The Microchip Web Site
• Development Systems Customer Change Notification Service
• Customer Support
• Document Revision History

DOCUMENT LAYOUT 
This document describes how to use the Buck/Boost Converter PICtail Plus Daughter 
Board as a development tool to emulate and debug firmware on a target board. The 
manual layout is as follows:
• Chapter 1. “Introduction” – This chapter describes the Buck/Boost Converter 

PICtail Plus Daughter Board and provides a brief description of the hardware.
• Chapter 2. “Hardware Overview” – This chapter describes the Buck/Boost 

Converter PICtail Plus Daughter Board hardware.
• Chapter 3. “Getting Started” – This chapter describes the step-by-step process 

for getting your Buck/Boost Converter PICtail Plus Daughter Board up and 
running with the MPLAB® In-Circuit Debugger 2 (ICD 2) using a 
dsPIC33FJ16GS502 device.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 
document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 
Select the Help menu, and then Topics to open a list of available on-line help files.
© 2008 Microchip Technology Inc. DS70336A-page 1
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• Chapter 4. “Demonstration Program Operation” – This chapter describes the 
operation of the Buck/Boost Converter PICtail Plus Daughter Board.

• Appendix A. “Schematics and Layouts” – This appendix illustrates the 
Buck/Boost Converter PICtail Plus Daughter Board layout and provides hardware 
schematic diagrams.

CONVENTIONS USED IN THIS GUIDE
This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS
Description Represents Examples

Arial font:
Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...
Initial caps A window the Output window

A dialog the Settings dialog
A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK
A tab Click the Power tab

N‘Rnnnn A number in Verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>
Courier New font:
Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}

DS70336A-page 2 © 2008 Microchip Technology Inc.



Preface
WARRANTY REGISTRATION 
Please complete the enclosed Warranty Registration Card and mail it promptly. 
Sending in the Warranty Registration Card entitles users to receive new product 
updates. Interim software releases are available at the Microchip web site.

RECOMMENDED READING
This user's guide describes how to use the Chapter Name. Other useful documents are 
listed below. The following Microchip documents are available and recommended as 
supplemental reference resources.
Readme for Chapter Name
For the latest information on using Chapter Name, read the “Readme.txt” (an ASCII 
text file) in the Readme subdirectory of the MPLAB IDE installation directory from the 
Buck/Boost Converter PICtail Plus Daughter Board CD. The Readme file contains 
update information and known issues that may not be included in this user’s guide.
Readme Files
For the latest information on using other tools, read the tool-specific Readme files in 
the Readme subdirectory of the MPLAB IDE installation directory. The Readme files 
contain updated information and known issues that may not be included in this user’s 
guide.
© 2008 Microchip Technology Inc. DS70336A-page 3
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THE MICROCHIP WEB SITE 
Microchip provides online support via our web site at www.microchip.com. This web 
site is used as a means to make files and information easily available to customers. 
Accessible by using your favorite Internet browser, the web site contains the following 
information:
• Product Support – Data sheets and errata, application notes and sample 

programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE 
Microchip’s customer notification service helps keep customers current on Microchip 
products. Subscribers will receive e-mail notification whenever there are changes, 
updates, revisions or errata related to a specified product family or development tool of 
interest.
To register, access the Microchip web site at www.microchip.com, click on Customer 
Change Notification and follow the registration instructions.
The Development Systems product group categories are:
• Compilers – The latest information on Microchip C compilers and other language 

tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM™ 
and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30 object linkers; 
and MPLIB™ and MPLAB LIB30 object librarians.

• Emulators – The latest information on Microchip in-circuit emulators.This 
includes the MPLAB ICE 2000, MPLAB ICE 4000, and MPLAB REAL ICE™ 
in-circuit emulator.

• In-Circuit Debuggers – The latest information on the Microchip in-circuit 
debugger, MPLAB ICD 2.

• MPLAB IDE – The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager 
and general editing and debugging features.

• Programmers – The latest information on Microchip programmers. These include 
the MPLAB PM3 and PRO MATE II device programmers and the PICSTART® 
Plus and PICkit™ 1 development programmers.
DS70336A-page 4 © 2008 Microchip Technology Inc.
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CUSTOMER SUPPORT 
Users of Microchip products can receive assistance through several channels:
• Distributor or Representative
• Local Sales Office
• Field Application Engineer (FAE)
• Technical Support
Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.
Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY 

Revision A (August 2008)
This is the initial release of this document.
© 2008 Microchip Technology Inc. DS70336A-page 5
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BOARD USER’S GUIDE
Chapter 1.  Introduction
Modern power supplies are becoming smaller, more efficient, more flexible and less 
expensive. These desirable enhancements have come about as digital signal controllers 
are incorporated into Switch Mode Power Supply (SMPS) designs. Buck converters are 
used when the desired output voltage is smaller than the input voltage. Boost converters 
are used when the desired output voltage is higher than the input voltage.
This chapter introduces and provides an overview of the Buck/Boost Converter PICtail 
Plus Daughter Board. The following topics are included in this chapter:
• Overview
• Features
• Product Package

1.1 OVERVIEW
The Buck/Boost Converter PICtail Plus Daughter Board (also referred to as Daughter 
Board) is a power supply board. It consists of two independent DC/DC synchronous 
buck converters and one independent DC/DC boost converter. Figure 1-1 illustrates a 
block diagram of the Daughter Board.
All of the necessary power, drive and control signals are available in the J1 and J2 con-
nectors. The 16-bit 28-pin Starter Development Board can be used to control one inde-
pendent DC/DC synchronous buck converters. This board can also control two buck 
stages, or one buck and one boost stage with hardware modification on the 16-bit 
28-pin Starter Development Board. Refer to Section 2.4.2 “16-bit 28-pin Starter 
Development Board Controls Buck 1 and Boost Stages” for more details.
The block diagram of the Daughter Board using the 16-bit 28-pin Starter Development 
Board is shown in Figure 1-2. All three stages of the Buck/Boost Converter PICtail Plus 
Daughter Board are controlled by the Explorer 16 Development Board. Figure 1-3 
shows a block diagram of the Daughter Board using the Explorer 16 Development 
Board. 
The control boards provide closed-loop Proportional-Integral-Derivative (PID) control in 
the software to maintain the desired output voltage level. The dsPIC® DSC device 
provides the necessary memory and peripherals for A/D conversion, PWM generation, 
analog comparison and general purpose I/O, excluding the need to perform these func-
tions in external circuitry.

SMPS dsPIC® DSC devices are specifically designed to provide low-cost and efficient 
control for a wide range of power supply topologies. The specialized peripherals 
facilitate closed-loop feedback control of switch mode power supplies, providing 
communication for remote monitoring and supervisory control.
The Daughter Board enables the end user to easily transition from analog-to-digital 
implementation of the power application. The Daughter Board also aids in rapid 
development of buck converter, boost converter, multi-phase buck converter and two 
parallel buck converters. 
© 2008 Microchip Technology Inc. DS70336A-page 7
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The dsPIC33F SMPS family of devices provides the following features: 
• Integrated program and data memory on a single chip 
• Ultra-fast interrupt response time and hardware interrupt priority logic 
• Up to 4 Msps, on-chip ADC with two SARs, and up to four dedicated and two 

shared sample/hold circuits for multiple loop control 
• Four independent, high-resolution PWM generators specially designed to support 

different power topologies 
• Four analog comparators for control loop implementation and system protection 
• On-chip system communications (I2C™/SPI/UART) 
• On-chip Fast RC oscillator for lower system cost 
• High-current sink/source for PWM pins: 16 mA/16 mA
• CPU performance: 40 MIPS
• Extensive power saving
• CodeGuard™ Security enabled

FIGURE 1-1: DAUGHTER BOARD BLOCK DIAGRAM
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Introduction
FIGURE 1-2: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD WITH DAUGHTER BOARD
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FIGURE 1-3: EXPLORER 16 DEVELOPMENT BOARD WITH DAUGHTER BOARD
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Introduction
1.2 FEATURES
The Buck/Boost Converter PICtail Plus Daughter Board provides the following 
features: 

1.2.1 Power Stages
• Two synchronous buck converter power stages
• One boost converter power stage 
• Voltage/current measurement for digital control of buck converters
• Voltage/current measurement for digital control of boost converter 
• Switchable, one 5Ω/5W resistive load on Buck Converter 1 output (VOUT1)
• Buck Converter 1 output (VOUT1) on J4 connector for external loading 
• Buck Converter 2 output (VOUT2) on J5 connector for external loading
• Boost Converter output (VOUT3) on J8 connector for external loading
• Connector J9 for auxiliary power input 

1.2.2 Additional Features
• 5 kΩ Potentiometer (RP1) connected via jumper J10
• Input voltage source selection via jumper J6
• Additional resistive load R46 via jumper J11
• Connectors J1 and J2 (Explorer 16/16-bit 28-pin Starter Development Board)
• PMBus™ Connector (J3)

1.2.3 Daughter Board Power
• Auxiliary power input (J9): +7V to +15V (+9V nominal)
• 9V power input is through input connectors J2 and J1
• LED power-on indicator (D14)
• LED output voltage indicators (D11, D12 and D13)

1.3 PRODUCT PACKAGE
The Buck/Boost Converter PICtail Plus Daughter Board kit consists of the following 
items: 
• Buck/Boost Converter PICtail Plus Daughter Board 
• Buck/Boost Converter PICtail Plus Daughter Board CD 
The CD consists of the application software, example code, Readme file and User’s 
Guide.

Note: 9V input is supplied from the controller card (16-bit 28-pin Starter 
Development Board or Explorer 16 Development Board). All 16-bit 28-pin 
Starter Development Boards should have a blue wire connecting Pin 1 of 
J1 to Pin 28 of J2. If no blue wire connects them, connect a wire between 
them to supply the 9V input to the Buck/Boost Converter PICtail Plus 
Daughter Board.
© 2008 Microchip Technology Inc. DS70336A-page 11
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BOARD USER’S GUIDE
Chapter 2.  Hardware Overview
This chapter lists and describes the hardware elements and components of the 
Buck/Boost Converter PICtail Plus Daughter Board (also referred to as Daughter 
Board). The following topics are included:
• Daughter Board Connectors 
• Using the Daughter Board with the Explorer 16 Development Board
• Using the Daughter Board with the 16-bit 28-pin Starter Development Board 
• Power Rating of Converter Stage
• Power Rating of Converter Stage

2.1 DAUGHTER BOARD CONNECTORS
The Daughter Board consists of different power sections along with the input and 
output connectors for signal and power connections. Figure 2-1 depicts the Daughter 
Board, the input and output connectors and their locations. 

FIGURE 2-1: BUCK/BOOST CONVERTER PICtail™ PLUS DAUGHTER BOARD
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1.  J1 – To connect Explorer 16 Development Board
2.  J2 – To connect 16-bit 28-pin Starter Development Board
3.  J3 – PMBus™ interface connector
4.  J4 – VOUT1 connector

5.  J5 – VOUT2 connector
6.  J8 – VOUT3 connector
7.  J9 – Auxiliary input power connector
© 2008 Microchip Technology Inc. DS70336A-page 13
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2.2 DAUGHTER BOARD USER HARDWARE INTERFACE
This section describes the hardware interface of the Daughter Board and the power 
rating of each converter’s section. Figure 2-2 displays the hardware elements (pin 
headers, jumpers, LED and potentiometer).

FIGURE 2-2: BUCK/BOOST CONVERTER PICtail™ PLUS DAUGHTER BOARD HARDWARE 
ELEMENTS

2.2.1 Auxiliary Input Power Connector
The Daughter Board can be connected to the auxiliary/bench power DC source through 
the J9 input connector. Jumper J6 should be removed while working with the 
auxiliary/bench power DC source. See Figure A-5 for the location of this jumper.

2.2.2 PMBus Interface Connector J3
The Daughter Board allows the user to implement the PMBus on the SMPS dsPIC  
DSC device using the J3 connector. See Figure A-6 for the location of this jumper.

Note: The Daughter Board only consists of the three power trains of the DC/DC 
converter sections. Either the 16-bit 28-pin Starter Development Board with 
the dsPIC33FJ16GS502 device, or the Explorer 16 Development Board 
with the dsPIC33FJ16GS504 device can be used to control the DC/DC 
power sections of the Daughter Board. The J1 and J2 connectors provide 
the necessary signals for control purposes.

D11J11 D12 D13

J2

J1

J6 J10D14 RP1
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2.2.3 16-bit 28-pin Starter Development Board Connector J2
The two converter stage sections of the Daughter Board can be controlled using the 
16-bit 28-pin Starter Development Board. Table 2-1 lists all of the power and signal 
connections on the Daughter Board J2 connector to the user interface with the 16-bit 
28-pin Starter Development Board. See Figure A-6 for the location of this connector.

TABLE 2-1: SIGNAL AND POWER CONNECTION FOR 16-BIT 28-PIN 
STARTER DEVELOPMENT BOARD (J2)

Pin Number 
Primary Assignment Primary Use

1 NC Not Connected
2 AN0 Analog Input 0 (Buck Converter 1 current)
3 AN1 Analog Input 1 (Buck Converter 1 voltage)
4 AN2 Analog Input 2 (Buck Converter 2 current)
5 AN3 Analog Input 3 (Buck Converter 2 voltage)
6 AN4 Analog Input 4 (Input Voltage)
7 NC Not Connected
8 VSS Ground reference for logic and I/O pins
9 NC Not Connected

10 NC Not Connected
11 NC Not Connected
12 NC Not Connected
13 VDD Positive supply for logic and I/O pins
14 NC Not Connected
15 RB15 PMBUSAUX2
16 RB5 PMBUSAUX1
17 SCL SCL/TX
18 SDA SCL/RX
19 VSS Ground reference for logic and I/O pins
20 VDD +3.3V_DIG
21 PWM3H PWM Boost Converter
22 I/O Load
23 PWM2H PWM 2 High Output (Buck Converter 2)
24 PWM2L PWM 2 Low Output (Buck Converter 2)
25 PWM1H PWM 1 High Output (Buck Converter 1)
26 PWM1L PWM 1 Low Output (Buck Converter 1)
27 NC Not Connected
28 +9V Input Voltage for two buck stages
© 2008 Microchip Technology Inc. DS70336A-page 15
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2.2.4 Explorer 16 Development Board Connector J1
The two buck sections and one boost section of the Daughter Board can be controlled 
using the Explorer 16 Development Board. Table 2-2 lists all the power and signal 
connections on the Daughter Board J1 connector to the user interface with the 
Explorer 16 Development Board. See Figure A-6 for the location of this connector.

TABLE 2-2: SIGNAL AND POWER CONNECTION FOR THE EXPLORER 16 
DEVELOPMENT BOARD (J1)

Pin Number 
Primary Assignment Primary Use

79 AN0 Analog Input 0 (Buck Converter 1 current)

80 AN1 Analog Input 1 (Buck Converter 1 voltage)
45 PWM1H PWM 1 High Output (Buck Converter 1 drive)
46 PWM1L PWM 1 Low Output (Buck Converter 1 drive)
8 AN2 Analog Input 2 (Buck Converter 2 current)
6 AN3 Analog Input 3 (Buck Converter 2 voltage)

12 PWM2H PWM 2 High Output (Buck Converter 2 drive)
11 PWM2L PWM 2 Low Output (Buck Converter 2 drive)
50 AN4 Analog Input 4 (Input Voltage)

102 AN8 Analog Input 8 (Boost Converter Voltage)
80 AN9 Analog Input 9 (Boost Converter Voltage)
17 PWM3H PWM3H High Output (Boost Converter drive)
13 I/O Load Drive for Buck Converter 1 Load

101 AN10 Analog Input 10 (POT RP1)
65 RB15 PMBUSAUX2
66 RB5 PMBUSAUX1
67 SCL SCL/TX
68 SDA SCL/RX

9, 10, 119, 120 3.3VDIG_GND Ground Reference for Digital I/O pins
21, 22, 53, 54, 

107, 108
+3.3V_DIG Digital 3.3V

15, 16, 41, 42 9VANA_GND Ground Reference for Logic and I/O pins
25, 26, 57, 58 +9V 9V Input Voltage

1-5, 14, 18-20, 23, 
24, 27-30, 33-40, 
43, 44, 49, 51, 52, 

55, 56, 59-62, 
69-78, 81-95, 

97-100, 103-106, 
109-118

NC Not Connected
DS70336A-page 16 © 2008 Microchip Technology Inc.
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2.2.5 VOUT1 J4 (Buck1+)
An external load can be connected to VOUT1 through the J4 connector. One 
on-board parallel resistor, R44 (5Ω/5W), is connected at the output of VOUT1 
through MOSFET Q13 to optionally load the Buck 1 converter circuit. Resistor R45 is 
on-board, and there is space to solder resistor R46 onto the board. When resistor 
R46 is connected to VOUT1, the J11 jumper must be open while working with +9V 
power from the control board. The on-board load resistor can be connected to 
VOUT1 by controlling the signal name “Load”. The “Load” signal is the I/O pin of the 
SMPS dsPIC DSC device, and is active-high. See Figure A-2 for the location of this 
connector.

2.2.6 VOUT2 J5 (Buck2+)
An external load can be connected to VOUT2 through the J5 connector. VOUT2 
can load up to a maximum of 3 amps when the auxiliary input voltage source is 
connected at the J9 input connector. See Figure A-3 for the location of this connec-
tor.

2.2.7 VOUT3 J8 (Boost)
An external load can be connected to VOUT3 through the J8 connector. VOUT3 can 
load up to 0.75 amps when the auxiliary input voltage source is connected at the J9 
input connector. See Figure A-4 for the location of this connector.

2.2.8 Jumpers
The Daughter Board consists of three jumpers that determine its features. Table 2-3 
lists jumpers and their functions.

TABLE 2-3: JUMPERS

2.2.9 Potentiometer and LED
The Daughter Board consists of a potentiometer and LEDs for the user application. 
Table 2-4 lists components and their functions.

TABLE 2-4: POTENTIOMETERS AND LED

Jumpers Description Default Configurations

J6 Select either 9V power provided by the Explorer 16 Develop-
ment Board or 16-bit 28-pin Starter Development Board, and 
an external power supply

Short with jumper header (closed)

J10 Connects potentiometer RP1 to AN10 on Explorer 16 Develop-
ment Board

Open

J11 Connects R46 load resistor to VOUT1 Open
J12 Buck 2 voltage feedback selection Short with jumper header (closed)
J13 Buck 2 current feedback selection Short with jumper header (closed)
J14 Boost current feedback selection Open
J15 Boost voltage feedback selection Open

Label Hardware Elements

RP1 Potentiometer connected to AN10 of Explorer 16 Development Board controller
D11 Buck 1 output LED
D12 Buck 2 output LED
D13 Boost output voltage LED
D14 Input voltage LED
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2.2.10 Test Points
The Daughter Board provides the various test points of the PWM signals, feedback 
signals and input and output voltages for the user application. Table 2-5 lists the PWM 
test points that can be used to check the PWM gate pulse for all three power stages. 

TABLE 2-5: PWM TEST POINTS

Table 2-6 lists the feedback signal test points that can be used to check the feedback 
signal waveforms and values. 

TABLE 2-6: FEEDBACK SIGNAL TEST POINTS

Table 2-7 shows the power test points that can be used to verify the input and output 
voltages.

TABLE 2-7: POWER TEST POINTS

Test Points Description

PWM1H Buck MOSFET gate drive of Buck 1 converter stage
PWM1L Synchronous MOSFET gate drive of Buck 1 converter stage
PWM2H Buck MOSFET gate drive of Buck 2 converter stage
PWM2L Synchronous MOSFET gate drive of Buck 2 converter stage
PWM3H Boost MOSFET gate drive for Boost converter stage

Test Points Description

Current Sense1 Current feedback signal for Buck 1 converter stage
Current Sense2 Current feedback signal for Buck 2 converter stage
Current Sense3 Current feedback signal for Boost converter stage

Test Points Description

V+ Input Voltage Test Point
Buck1+ VOUT1 voltage test point
Buck2+ VOUT2 voltage test point
Boost+ VOUT3 voltage test point
GND Ground potential test point
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2.3 USING THE DAUGHTER BOARD WITH THE EXPLORER 16 DEVELOPMENT 
BOARD

This section describes the hardware connection of the Daughter Board with the 
Explorer 16 Development Board. Figure 2-3 displays the Daughter Board hardware 
connection (MPLAB ICD 2 and power supply) to the Explorer 16 Development Board. 
The dsPIC33FJ16GS504 SMPS device controls both buck stages (Buck 1 and Buck 
2), as well as the boost stage through the Explorer 16 Development Board 
simultaneously.

The potentiometer R6 (10 kΩ), in series with the R12 resistor on the Explorer 16 
Development Board, is connected to analog input channel (AN5) of the SMPS dsPIC  
DSC device. The potentiometer R6 on the Daughter Board is connected to the analog 
input channel (AN10) through the J10 jumper. Both potentiometers can be used for 
development purposes to simulate any feedback signal.

FIGURE 2-3: DAUGHTER BOARD CONNECTED TO THE EXPLORER 16 DEVELOPMENT 
BOARD

Note: To operate all three converters using the Explorer 16 Development Board, 
ensure that J12, J13 and J6 are shorted with the jumper header, and J14 
and J15 are open before powering up the board. 

MPLAB® ICD 2

MPLAB ICD 2 

+9V Power Supply Connector Explorer 16 Development BoardBuck/Boost Converter PICtail™ Plus Daughter Board

Connector
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2.4 USING THE DAUGHTER BOARD WITH THE 16-BIT 28-PIN STARTER 
DEVELOPMENT BOARD

This section describes the use of a 16-bit 28-pin Starter Development Board with the 
Buck/Boost Converter PICtail Plus Daughter Board.
Figure 2-4 shows the 16-bit 28-pin Starter Development Board and its hardware 
elements. For more details, refer to the “16-Bit 28-Pin Starter Development Board 
User's Guide” (DS51656), which is available from the Microchip website 
(http://www.microchip.com).

FIGURE 2-4: 16-BIT 28-PIN STARTER DEVELOPMENT BOARD

The potentiometer, RP1 (10 kΩ), with the J5 jumper on the 16-bit 28-pin Starter 
Development Board, is connected to the analog input channel (AN5) of the SMPS 
dsPIC DSC device. Figure 2-5 shows the connection of a 16-bit 28-pin Starter 
Development Board to a Daughter Board with ICD 2 and a 9V power supply. 
Ensure that the following changes are made to the 16-bit 28-pin Starter Development 
Board prior to connecting the 16-bit 28-pin Starter Development Board to the Daughter 
Board:
• Remove resistors R14 and R15 (to control Buck 2 or Boost converter)
• JP1 in pin 1-2 position (supply)
• JP2 in pin 2-3 position (+3.3V)
• JP3 in 1-2 position (dsPIC33F/PIC24)
• JP4 open
• SW2 in USB/DEBUG mode

JP1
JP2

JP3

JP4

R14

R15

R17

R16

SW2
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FIGURE 2-5: DAUGHTER BOARD HARDWARE CONNECTED TO A 16-BIT 28-PIN STARTER 
DEVELOPMENT BOARD

2.4.1 16-bit 28-pin Starter Development Board Controls Buck 1 and 
Buck 2 Stages (Default Jumper Configuration)

The dsPIC33FJ16GS502 SMPS device controls buck stages Buck 1 and Buck 2 
through the 16-bit 28-pin Starter Development Board as the default configuration on the 
Daughter Board, refer to Table 2-3. The two buck stages can be controlled as 
multi-phase or as two parallel converters by shorting the VOUT1 (Buck1+) and VOUT2 
(Buck2+) output, and by programming the output of buck stages to the same output 
voltage value.

2.4.2 16-bit 28-pin Starter Development Board Controls Buck 1 and 
Boost Stages

This section describes the hardware changes that must be performed to control the 
Buck 1 and Boost stages. Figure 2-6 displays the feedback jumper, which must be 
modified in the Daughter Board. See Figure A-4 for the complete Daughter Board 
schematics.

 MPLAB® ICD 2

MPLAB ICD 2 

16-bit 28-pin Starter Development Board

+9V Power Supply Connector

Buck/Boost Converter PICtail™ Plus Daughter Board

 Connector

Note 1: To operate the two buck converters using the 16-bit 28-pin Starter Devel-
opment Board, ensure that J12, J13 and J6 are shorted with the jumper 
header, and J14 and J15 are open before powering up the board. 

2: The software file Buck1 Voltage Mode with 28P Starter Board 
on the Buck/Boost Converter PICtail Plus Daughter Board CD only 
provides control for the Buck 1 stage.
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FIGURE 2-6: FEEDBACK JUMPERS

2.4.2.1 HARDWARE

The following hardware changes are required in the Daughter Board to enable control 
of the Buck 1 and Boost stage:
• Jumper J12 and J13: Open
• Jumper J14 and J15: Short with jumper header (close)

2.4.2.2 SOFTWARE

The following additional changes in software are required to enable control of the Buck 
1 and Boost stage:
• Boost Current feedback through analog input channel (AN2)
• Boost Voltage feedback through analog input channel (AN3)
• Boost PWM output (PWM3H)
• PWM2 output pin must be controlled by I/O port and driven low

J12

J13

J14

J15

Note: The software file Buck1 Voltage Mode with 28P Starter Board 
on the Buck/Boost Converter PICtail Plus Daughter Board CD only provides 
control for the Buck 1 stage.
DS70336A-page 22 © 2008 Microchip Technology Inc.



Hardware Overview
2.5 POWER RATING OF CONVERTER STAGE
All three DC/DC power stages in a Daughter Board can be loaded externally through 
the output terminal blocks J4, J5 and J8. For loading any power stage externally, the 
user must provide an auxiliary power source to the Daughter Board through input 
terminal block J9.

2.5.1 Buck 1 Converter
The Buck 1 converter stage is rated for a maximum output current of 3 amps through 
the J4 connector. The output voltage of the buck converter (VOUT1) can be pro-
grammed for 0V-5V output. The hardware gain [5k/(3.3k + 5k)] of the voltage feedback 
of VOUT1 is provided by the resistor divider network of R11 and R12. The hardware 
gain of the current feedback is provided by the current transformer (Tx1) with turns ratio 
(1:60) and burden resistor R5. The circuitry consists of R6, R7, C7 and Q3, and 
provides slope compensation for current feedback (Current Sense1).

2.5.2 Buck 2 Converter
The Buck 2 converter stage is rated for a maximum output current of 3 amps through 
the J5 connector. The output voltage of the buck converter (VOUT2) can be pro-
grammed for 0V-5V output. The hardware gain [5k/(3.3k + 5k)] of the voltage feedback 
of VOUT2 is provided by the resistor divider network of R29 and R30. The hardware 
gain of the current feedback is provided by the current transformer (Tx2) with turns ratio 
(1:60) and burden resistor R23. The circuitry consists of R24, R25, C14 and Q8, and 
provides slope compensation for current feedback (Current Sense2).

2.5.3 Boost Converter
The Boost converter stage is rated for a maximum output current of 0.75 amps through 
the J8 connector. The output voltage of the boost converter (VOUT3) can be 
programmed up to a maximum output of 20V. The hardware gain [20k/(20k + 3.3k)] of 
the voltage feedback of VOUT3 is provided by the resistor divider network of R55 and 
R56. The hardware gain of the current feedback is provided by the current sense 
resistor R53 (current sense boost/Current Sense3). The circuitry consists of R13, R14, 
C20 and Q4 and provides slope compensation for current feedback 
(current sense boost/Current Sense3).
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Chapter 3.  Getting Started
This chapter provides details to get started using the Daughter Board with the 16-bit 
28-pin Starter Development Board using the dsPIC33FJ16GS502 SMPS device. The 
16-bit 28-pin Starter Development Board is modified as per Section 2.4 “Using the 
Daughter Board with the 16-bit 28-pin Starter Development Board”. While working 
with the Daughter Board along with the Explorer 16 Development Board using a 
dsPIC33FJ16GS504 device, please refer to the Explorer 16-specific note that is 
specified in the corresponding instructions.
The following topics are covered in this chapter:
• Overview
• Creating the Project
• Building the Code
• Programming the Device
• Debugging the Code

3.1 OVERVIEW
This section describes the main features of MPLAB IDE and the MPLAB ICD 2 
In-Circuit Debugger because they are used in the 16-bit 28-pin Starter Development 
Board. This section provides information on performing the following tasks:
1. Creating a project using the Project Wizard.
2. Assembling and linking the code, and setting the Configuration bits.
3. Setting up MPLAB IDE to use the MPLAB ICD 2 In-Circuit Debugger.
4. Programming the chip with MPLAB ICD 2.
5. Viewing code execution.
6. Viewing registers in the Watch window.
7. Setting a breakpoint and setting the code halt in the specific location.
8. Using the function keys to Reset, Run, Halt and Single Step the code.
Before performing these steps, save the Buck/Boost Converter PICtail Plus Daughter 
Board firmware from the CD in the following location: C:\Program Files\Microchip\

Note 1: The demo software using 16-bit 28-pin Starter Development Board will be 
under folder: C:\Program Files\Microchip\Buck Boost 
PICtail Plus Board\Buck1 Voltage Mode with 28P Starter 
Board.

2: The demo software using Explorer 16 Development Board will be under 
the folder: C:\Program Files\Microchip\Buck Boost PICtail 
Plus Board\3-Stage Voltage Mode with Explorer 16

3: Both the above folders comprise of the project file (*.mcp) and 
workspace file (*.mcw). The user can use these files to program the 
device, or the user can create their own project and workspace file by 
performing the steps listed in this Chapter. 
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3.2 CREATING THE PROJECT
This section describes the process of creating a project and workspace in MPLAB IDE. 
In any particular folder, one project and one workspace are present.

A project consists of files that are used to build an application (source code, linker script 
files, etc.) along with their association to various build tools and build options. The 
workspace consists of the following features:
• One or more projects
• Information on the selected device
• Debug tool and/or programmer, open windows and their location
• Other IDE configuration settings
MPLAB IDE provides a Project Wizard to create new projects.

3.2.1 Creating the Project
Using the Project Wizard involves four steps:
• Selecting the Device
• Selecting the Language Toolsuite
• Naming the Project
• Adding Files to the Project
Use the following procedures to complete each of the four steps.

Note: These instructions presume the use of MPLAB IDE v8.10 or later.
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3.2.1.1 PROJECT WIZARD STEP ONE – SELECTING THE DEVICE

1. Start MPLAB IDE.
2. Close any open workspace (File>Close Workspace).
3. Select Project>Project Wizard. The Welcome dialog appears.
4. Click Next to continue. The Select a device dialog appears.
5. From the Device drop-down list, select the required device, as shown in 

Figure 3-1.

FIGURE 3-1: SELECT A DEVICE

6. Click Next to continue. The Select a language toolsuite dialog appears, as 
shown in Figure 3-2.

Note: While using the Explorer 16 Development Board, select the 
dsPIC33FJ16GS504 device.
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3.2.1.2 PROJECT WIZARD STEP TWO – SELECTING THE LANGUAGE 
TOOLSUITE

1. As shown in Figure 3-2, select Microchip C30 Toolsuite from the Active Toolsuite 
drop-down list. This toolsuite includes the assembler and linker that is to be used 
in the project.

FIGURE 3-2: SELECT LANGUAGE TOOLSUITE

2. Select MPLAB C30 C Complier (pic30-gcc.exe) from the Toolsuite Contents 
options.

3. Click Next to continue. The Create a new project, or reconfigure the active 
project? dialog appears, as shown in Figure 3-3.

Note: To create a project that consists of source files written in a language other 
than Microchip Assembly, select the specific language toolsuite from the 
drop-down menu.
DS70336A-page 28 © 2008 Microchip Technology Inc.



Getting Started
3.2.1.3 PROJECT WIZARD STEP THREE – NAME YOUR PROJECT

1. As shown in Figure 3-3, under Create New Project File, click Browse..., and 
navigate to:
C:\Program Files\Microchip\Buck BoostPicTail Plus Board\Buck1 
Voltage Mode with 28P Starter Board.

FIGURE 3-3: NAME YOUR PROJECT

2. In the resulting Save Project As dialog, enter the project name as Buck1 Voltage 
Mode.mcp, and then click Save.

3. Click Next to continue. The Add existing files to your project dialog appears, as 
shown in Figure 3-4.

Note: While using the Explorer 16 Development Board, navigate to the following 
path in the “Create New Project File”: C:\Program 
Files\Microchip\Buck Boost PicTail Plus Board\3-Stage 
Voltage Mode with Explorer 16.

Note: While using the Explorer 16 Development Board, enter the project name as 
3-Stage Voltage Mode.mcp.
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3.2.1.4 PROJECT WIZARD STEP FOUR – ADD FILES TO YOUR PROJECT

1. As shown in Figure 3-4, from the left pane, navigate to C:\...\Buck1 
Voltage Mode with 28P Starter Board, and select the following files:
• init.c

• isr.c

• main.c

• dsp.h

• function.h

• dspcommon.inc

• isr_asm.s

• pid.s

FIGURE 3-4: ADD FILES TO PROJECT

2. Click Add to include the files in the project. The selected files appear in the right 
pane.

3. Click Next to continue. The Summary dialog appears as shown in Figure 3-5.

Note: While using the Explorer 16 Development Board, navigate to the following 
path: C:\program Files\Microchip\Buck Boost PICtail Plus 
Board\3-Stage Voltage Mode with Explorer 16, and select the 
following files:
• init.c

• isr.c

• main.c

• dsp.h

• function.h

• dspcommon.inc

• isr_asm.s

• pid.s
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3.2.1.5 PROJECT SUMMARY

Click Finish to complete the project.

FIGURE 3-5: SUMMARY DIALOG

After completing the project wizard, the MPLAB IDE project window lists the following 
files in the Source Files folder:
• isr.c

• main.c

• isr_asm.s

• pid.s

• init.c

Note: While using the Explorer 16 Development Board, the MPLAB IDE project 
window lists the following files in the Source Files folder:
• init.c

• isr.c

• main.c

• isr_asm.s

• pid.s
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3.2.1.6 VIEWING THE PROJECT

1. Click View>Project from the MPLAB IDE menu, as shown in Figure 3-6.

FIGURE 3-6: OPEN PROJECT FILE

The Buck1 Voltage Mode.mcw dialog appears, as shown in Figure 3-7. A 
project, Buck1 Voltage Mode.mcp, and workspace, Buck1 Voltage 
Mode.mcp, are created in MPLAB IDE.

Note: While using the Explorer 16 Development Board, the 3-Stage Voltage 
Mode.mcp appears. A 3-Stage Voltage Mode.mcp project and 
workspace, 3-Stage Voltage Mode.mcw, are created in MPLAB IDE.
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FIGURE 3-7: MPLAB® IDE PROJECT WINDOW

2. Double click the main.c file in the project window to open the file. The MPLAB 
IDE Workspace Window appears, as shown in Figure 3-8. This completes the 
project view process.
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FIGURE 3-8: MPLAB® IDE WORKSPACE WINDOW

3.3 BUILDING THE CODE
Building the code consists of the following process:
• Assembling all of the *.c and *.s files to create the respective object files (*.o)
• Linking the object files to create the 3-Stage Voltage Mode.hex and 
3-Stage Voltage Mode.cof output files

The .hex file contains the specific data to program the device. The .cof file contains 
additional information to debug at the source code level.
Before building the code, the user must set MPLAB ICD 2 to search for include files 
and to reserve space for the extra debug code.
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3.3.1 Building the Code
To specify the Project Build Options:
1. Select Build Options>Project from the Project menu. The Build Options For 

Project “Buck 1 Voltage Mode.mcp” dialog appears, as shown in Figure 3-9.

FIGURE 3-9: BUILD OPTIONS

2. Select Assemble/Compile/Link in the project directory, and then click OK. This 
completes the code build process.

3.3.2 Linking the ICD 2 for Debugging
Select the Debug option from the drop-down menu of MPLAB IDE, as shown in 
Figure 3-10, so the linker will build the code for debugging. This sets aside the RAM for 
the MPLAB ICD 2 for use during debugging. If this is not performed, the MPLAB ICD 2 
will not function properly in Debug mode.
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FIGURE 3-10: LINK PROJECT FOR MPLAB® ICD 2

3.3.3 Building the Project
To build the project:
1. Select Project>Build All from the MPLAB IDE menu, as shown in Figure 3-11. 

FIGURE 3-11: DualBuck MPLAB® IDE SCREEN
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2. Observe the progress of the build in the Output window, as shown in Figure 3-12. 
This completes the project build process.

The device can be programmed if the build status is BUILD SUCCEEDED. If the build 
status is BUILD FAILED, the build errors that are listed must be resolved.

FIGURE 3-12: BUILD OUTPUT WINDOW
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3.4 PROGRAMMING THE DEVICE
The MPLAB ICD 2 In-Circuit Debugger can be used to program and debug the 
dsPIC33FJ16GS502 device in-circuit on the Daughter Board.

3.4.1 Setting up the Device Configuration
1. Select Configure>Configuration Bits from MPLAB IDE to display the 

configuration settings, as shown in Figure 3-13. The Configuration Bits window 
appears, as shown in Figure 3-14.

FIGURE 3-13: CONFIGURATION MENU

2.  Set the Configuration bits as highlighted in Figure 3-14.

FIGURE 3-14: CONFIGURATION SETTINGS

Note: Before proceeding, ensure that the USB driver for the MPLAB ICD 2 is 
installed on your PC. Refer to the “MPLAB® ICD 2 In-Circuit Debugger 
User’s Guide” (DS51331) for details.
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3.4.2 Connecting the MPLAB ICD 2 In-Circuit Debugger
1. Connect the MPLAB ICD 2 to the PC using the USB cable.
2. Connect the MPLAB ICD 2 to the 16-bit 28-pin Starter Development Board with 

the short RJ-11 (telephone) cable. Apply +9V power to the 16-bit 28-pin Starter 
Development Board.

FIGURE 3-15: DAUGHTER BOARD CONNECTED TO MPLAB® ICD 2 IN-CIRCUIT DEBUGGER
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3.4.3 Enabling the MPLAB ICD 2 Connection
1. Select Debugger>Select Tool>MPLAB ICD 2 to designate the MPLAB ICD 2 as 

the debug tool in MPLAB IDE, as shown in Figure 3-16.

FIGURE 3-16: SELECTING THE DEBUGGER

2. Select Debugger>Connect to connect the debugger to the device. 
The MPLAB ICD 2 should report that it found the dsPIC33FJ16GS502 device, as 
shown in Figure 3-17.
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FIGURE 3-17: ENABLING MPLAB® ICD 2

3. Select Debugger>Settings to display the MPLAB ICD 2 Debugger settings.
4. Select the Program tab on the Debugger settings dialog box.
5. Select the Allow ICD 2 to select memories and ranges radio button, as shown in 

Figure 3-18. This setting will speed up operations by programming only a small 
part of the total program memory.

Note: If this is the first time that the MPLAB ICD 2 is being used with a dsPIC33F 
device, it may need to download the new firmware. If any errors are shown, 
double click the error message to get more information.
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FIGURE 3-18: SETTING PROGRAM MEMORY SIZE
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3.4.4 Programming the dsPIC33FJ16GS502 Device
To program the device:
1. From the Debugger, select Debugger>Program. 

The Output (Program Memory window), as shown in Figure 3-19, displays the 
program statuses as they appear.

FIGURE 3-19: PROGRAMMING THE dsPIC33FJ16GS502 DEVICE

2. Observe the process in the Output window. When MPLAB ICD 2 Ready appears, 
the device is programmed and ready to run.

3. Select Debugger>Reset to reset the code.
4. Select Debugger>Run to run the code.
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3.5 DEBUGGING THE CODE
The MPLAB ICD 2 In-Circuit Debugger can be used to run, halt, and step the code. A 
breakpoint can be set to halt the program after the code has executed the instruction 
at the breakpoint. The contents of the RAM and registers can be viewed whenever the 
processor has been halted.
The MPLAB ICD 2 In-Circuit Debugger uses the following function keys to access the 
main debugging functions:
• <F5> – Halt
• <F6> – Reset
• <F7> – Single Step
• <F9> – Run
In addition to these, there are more functions accessible by right clicking on a line of 
source code. The most important of these are “Set Breakpoint” and “Run to Cursor”.

3.5.1 Displaying the Code
To display the code:
1. Select View>Program Memory.
2. From the Program Memory window, select the Symbolic tab, as shown in 

Figure 3-20.

FIGURE 3-20: PROGRAM MEMORY WINDOW
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3. Press <F5> to halt the processor and press <F6> to reset the processor. The 
Program Memory now displays a green arrow pointing to the line of code at 
address 0.

The instruction at this location is goto 0x000100. This code is added by the linker to 
make the program branch to the start of the code in the main.c file. The executable 
code starts from location 0x000100.

3.5.2 Stepping the Program
To step the program:
1. Press <F7> to single step the code. The green arrow now points to the code 

below ACLKCONbits.ENAPLL = 1; in the main.c source code, as shown in 
Figure 3-21.

FIGURE 3-21: SOURCE CODE WINDOW

2. Right click the instruction up to which the code is to be executed and select Run 
to Cursor.
The program is executed up to the instruction selected. 

3. Select View>Watch. The Watch window appears, as shown in Figure 3-22.
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FIGURE 3-22: WATCH WINDOW

4. Select DTR1 from the Add SFR drop-down list and click Add SFR to add the 
DTR1 register in the Watch window.

5. Select PWMCON1 from the Add SFR drop-down list and click Add SFR to add 
the PWMCON1 register in the Watch window.

6. Select ADCON from the Add SFR drop-down list and click Add SFR to add the 
ADCON register in the Watch window.

You will be able to see these registers change as you step through the code.

3.5.3 Setting the Breakpoint
1. To set a breakpoint, right click a line of code and select Set Breakpoint from the 

pop-up menu. 
For example, find the following line of code and set a breakpoint on this line:
ACLKCONbits.FRCSEL = 1;

A red octagonal shape marked with a B appears in the gutter (gray bar on the 
left) of the source code window to designate the breakpoint location, as shown 
in Figure 3-23.
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FIGURE 3-23: SETTING BREAKPOINT

2. Press <F9> to run the code.
The program halts on the instruction following the breakpoint.

Note: An alternate method to set a breakpoint is to simply double click the line. 
This feature may need to be enabled using the Edit>Properties menu.
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Chapter 4.  Demonstration Program Operation
The Buck/Boost Converter PICtail Plus Daughter Board CD supplied with the 
Buck/Boost Converter PICtail Plus Daughter Board consists of the source code for the 
16-bit 28-pin Starter Development Board (Buck 1 stage only) and Explorer 16 Develop-
ment Board (Buck 1, Buck 2 and Boost stages). To demonstrate a program that illus-
trates PID control of the output voltage on the Daughter Board, program the device with 
respective source code, available on the Daughter Board’s CD, specified in 
Section 3.2 “Creating the Project”. The code can also be downloaded from the 
Microchip web site (http://www.microchip.com).
The following topics are included in this chapter:

• Program Demonstration
• Code Demonstration
• Other Code Examples

4.1 PROGRAM DEMONSTRATION
The demonstration program provides simultaneous closed-loop control of the output 
voltages.
The PID control scheme consists of the following parameters:

• Proportional Error Gain (P-Gain) – This parameter produces a correction factor 
that is proportional to the magnitude of the output voltage error.

• Integral Error Gain (I-Gain) – This parameter uses the cumulative voltage error 
to generate a correction factor that eliminates any residual error due to limitations 
in offset voltages and measurement resolution.

• Derivative Error Gain (D-Gain) – This parameter produces a correction factor 
that is proportional to the rate of change of the output error voltage, which helps 
the system respond quickly to changes in system condition.

Additional control parameters that the user can add to P, I and D Gain terms are as 
follows:

• Second Derivative, or Jerk Error, Gain (J-Gain) – This parameter produces a 
correction factor that is proportional to the change in the differential error (i.e., the 
derivative of the derivative). J-Gain is a high frequency term that tends to provide 
quick response to an impulse event.

• Feed Forward Gain – This parameter produces a correction factor based on the 
desired output voltage that is computed based on the magnitude of the input 
voltage, inductor current, and circuit attributes (i.e., inductor and capacitor 
values). This term allows the control loop to be proactive rather than reactive. In 
other words, when the input voltage changes, feed forward gain responds so that 
the control loop does not have to wait until the output voltage changes before 
making the appropriate gain correction. 
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• Dead-Time Gain – This parameter produces a correction factor that compensates 
for the fact that the feed forward gain term does not account for the energy lost 
due to the dead time of the PWM signal (the time when both MOSFETs are off).

• Current-Limit Gain – This parameter limits the cumulative control gain when the 
current is approaching its upper limit.

After the modifications have been made to the 16-bit 28-pin Starter Development 
Board, as specified in Section 2.4 “Using the Daughter Board with the 16-bit 28-pin 
Starter Development Board”, do the following:

• Connect the power supply
• Connect the MPLAB ICD 2
• Connect the Buck/Boost Converter PICtail Plus Daughter Board
• Connect the 9V power supply to the 16-bit 28-pin Starter Development Board as 

shown in Figure 2-5
Instructions for programming the dsPIC33FJ16GS502 SMPS device are provided in the
Readme file of the respective software folder. Chapter 4. “Demonstration Program
Operation” also describes how to program the dsPIC33FJ16GS502 device using the
MPLAB ICD 2. Figure 4-1 illustrates the program flow of the demonstration program.

FIGURE 4-1: SMPS DEMONSTRATION PROGRAM FLOW CHART

Note: While using the Explorer 16 Development Board with the Daughter Board, 
the output voltages Buck1+, Buck2+ and Boost+ can be verified by 
measuring at output terminals J4, J5 and J8 respectively.

Initialization Routines:
• Peripherals – ADC, PWM, Timers, GPIO, etc.
• Variables – PID Gain Terms, Data Buffers
• Constants – Desired Voltage, Current Limit, etc.
• Interrupts – ADC, Timers

Idle Loop Functions: Wait for ADC Interrupt

Soft Start Routine

ADC Interrupt Routines:
• Measure VOUT

• Calculate PID Gain
• Update PWM Duty Cycle

START

 

ADC Interrupt

Exit ISR
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4.2 CODE DEMONSTRATION

4.2.1 System Initialization
When power is applied to the board, the program starts by executing the following system 
initialization routines:

• Peripherals – The required peripherals (PWM, ADC, Timers and GPIO) are 
configured and enabled.

• Variables – Program variables are defined. RAM locations and register usage are 
defined and documented.

• Constants – Program constants are defined including reference set points for 
both VOUT1 and VOUT2, input voltage, current limits, fault conditions, PWM 
periods and Timer periods. 

• Interrupts – The ADC and Timer Interrupts are set up and enabled.
• System Stabilization – All outputs are discharged to ensure a stable value at 

start-up.

4.2.2 Fault Check
The program checks the ADC for input undervoltage and output overvoltage conditions. 
If a fault occurs, the PWM outputs are disabled until the fault condition is cleared. If no 
fault is detected, the program proceeds.

4.2.3 Soft Start
The Soft Start Routine ramps up the output voltage in an open-loop fashion to bring the 
system within the operating range of the PID control loop. This routine ensures that the 
output does not overshoot the desired voltage. It also limits the current at start-up.

4.2.4 ADC Interrupt
The ADC Interrupt is the heart of the demo program. This routine takes up approximately 
75% of the execution time. It performs all the PID calculations and applies any needed 
corrections to the output.

4.2.5 System Idle Loop

All auxiliary functions are performed in the system idle routine. This is the time available 
to the CPU while the demo program is waiting for an ADC Interrupt. Non-critical functions 
can be performed in this loop. During this time the input voltage, fault timers and Soft 
Start flag are checked.

4.3 OTHER CODE EXAMPLES
There are several other code examples are available on the Microchip website. Refer 
to the Readme files located in each code example folder for details on what each code 
example demonstrates. Check the Microchip web site (http://www.microchip.com) for 
the latest updates to the code examples and for additional code examples.

Note 1: The ADC Interrupt can occur any time during program execution. 
2: The ADC Interrupt takes priority over any other tasks that the program is 

performing.
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Appendix 1. Schematics and Layouts
This appendix provides the board layout followed by schematics for the Buck/Boost 
Converter PICtail Plus Daughter Board.

FIGURE 1-1: BOARD LAYOUT
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FIGURE 1-2: DAUGHTER BOARD SCHEMATIC 1 OF 5
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FIGURE 1-3: DAUGHTER BOARD SCHEMATIC 2 OF 5
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FIGURE 1-4: DAUGHTER BOARD SCHEMATIC 3 OF 5

V
O

U
T3

20
V/

0.
75

A

St
ag

e 
3 

B
oo

st

D

G

S

9V
A

N
A_

G
N

D

9V
A

N
A

_G
N

D

L5 22
uH

9V
AN

A
_G

N
D

C28

0.1uF

C5

0.47nF

Q14

FDT459N

C24

0.1uF
C25

R
52

22
R

 1
%

 1
/8

W
D

9

B
A

S
16

+9
V

R53

0.5R

R
54

1k

C26

4.7uF 25V

C27

220uF 25V Elec

J8

R55

20k 1% 1/8W

R56

3.3k

D13

LED_0805

R59

10k

9V
A

N
A

_G
N

D

D
10

Sc
ho

ttk
y

TP
12 Bo

os
t+

TP
13

G
N

D

R13

20k 1% 1/8W

R14

2.2k 1% 1/8W

C20

2.2nF 25V

R15

5.1k

+3
.3

V
_D

IG

9V
A

N
A

_G
N

D

Q4

BSR14_SOT23
9V

A
N

A
_G

N
D

V
ol

ta
ge

 F
B

 B
oo

st

U
3

TC
14

28
C

O
A

R
34

3.
3K

+3
.3

V
_D

IG
P

W
M

3H

IN
B

V
ol

ta
ge

 F
B

2

Cu
rre

nt
 S

en
se

3

IN
A

N
C

V S
S

N
C

O
U

TA V
D

D

O
U

TB

A

A A

A

A

B

B B

B

B

AB
R

54

A
B

AB

V
IN

AB

ABAB

BA
0.1uF

C4

J1
5

AB

AB

AB

8 7 56

C
ur

re
nt

 S
en

se
2

J1
4

DS70336A-page 56 © 2008 Microchip Technology Inc.



Schematics and Layouts
FIGURE 1-5: DAUGHTER BOARD SCHEMATIC 4 OF 5
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