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1.Description

Lora RA-08H Node Board is a development board based
on the combination of Raspberry Pi RP2040 main control
chip and RA-08H, multiple Crowtail general IO interfaces,
can be used with Crowtail series modules. The onboard
Lorawan module is connected to the Lorawan platform to
realize remote module control, which can be applied to
maker education, smart home, industrial control, etc.

Model: CRT01261N
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2.Feature

Integrate RP2040 and RA-08H (Lorawan module)

Main control Raspberry Pi chip RP2040, built-in 264KB
SRAM, onboard 4MB Flash

Dual Core Arm Cortex-M0+ @ 133MHz

RA-08H module adopts embedded memory, 128KB Flash,
16KB SRAM

RA-08H module supports frequency band: 803MHZ-930MHZ
RA-08H module supports external antenna, SMA interface or
IPEX first generation interface

Compatible with Arduino/Micropython

6 5V Crowtail interfaces (2 analog interfaces, 2 digital
interfaces, 1 UART interfaces, 1 IIC interfaces)

2*10 universal GPIO interfaces

1 Battery interface

1 Solar interface

3.Technical Specification

Working input voltage: USB 5V-1A
Operating temperature range: -10°C ~ 65°C
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4 .Interface Function
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Name Interface/Function Definition
USB-C interface, it is used for the power supply
USB-C of the development board and the communication
interface between PC and RP2040.
PWR Power Indicator
RST Reset button, press this button to reset the
system.
Download button, hold down the Boot button and
ress the RESET button to enter boot firmware
(RP2040)BOOT | © y mw

download mode. Users can download firmware
through the USB interface.

(RA-08H)BOOT

Long press the download button before
power-on. Connect the external USB-to-serial
port module. Connect the cables to the external
USB-to-serial port module according to
(GND~GND, RA-3V~3.3V, RA-RX~TX,
RA-TX~RX) and update the firmware of the
RA-08H module through the
TremoProgrammer_v0.8 software.
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USB-C interface, it is used for the power supply
USB-C of the development board and the communication
interface between PC and RP2040.

3*14PIN, 3.3V general-purpose 10 header
GND-3V3-SIG |interface, which can be used for external 3.3V
sensor modules or devices.

External Crowtail-5V-HY-4P-2.0 port. Sensors or
Crowtail-A0 modules that can be used to interface with 5V
Crowtail analog signals.

External Crowtail-5V-HY-4P-2.0 port. Sensors or
Crowtail-A1 | modules that can be used to interface with 5V
Crowtail analog signals.

External Crowtail-5V-HY-4P-2.0 port. Sensors or
Crowtail-DO0 | modules that can be used to interface with 5V
Crowtail digital signals.

External Crowtail-5V-HY-4P-2.0 port. Sensors or
Crowtail-D1 | modules that can be used to interface with 5V
Crowtail digital signals.

External Crowtail-5V-HY-4P-2.0 port. Sensors or
Crowtail-UART | modules that can be used to connect to 5V
Crowtail UART serial communication.

External Crowtail-5V-HY-4P-2.0 port. Sensors or
Crowtail-I2C | modules that can be used to connect to 5V
Crowtail 12C interface communication.

BAT None.

SOLAR None.
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5.Usage
Development Environment Construction

1. Directly visit the Arduino official website and download the
Arduino development tools supported by the device. The link is as
follows: https://www.arduino.cc/en/software.

DOWNLOAD OPTIONS
.[:IE Arduino IDE 2.0.4 WIndowWs w10 ard rewm, 64 bits
Windows Wi instaker

Windows @
The new major release of the Arduino IDE is faster and een
mare powertul! In addition [o.a more moderm editor and a
more responsive interface it features autocompletion, code
navigation, and even a live debugger. machs inisl 10,14 o

machs Apgle Slcan,

Linu Appimage 64 his {556 54)

Linux ZIP ffe 64 bits (B6-64)

For more detalls, F\|E‘35E refer ta the Arduino [DE 2.0
documentation. Hezlpase Hlay

Mightly builds with the latest bugfixes are availabde through
the saction balow

SOURCE CODE
The Arduino IDE 2.0 is open source and Its source code is
hosted on GitHub.

2. Click the downloaded Arduino development tool to install the
software. After the software installation is complete, open it directly,
as shown in the figure below:

a sketch_maridla | Arduino 1.8.19 - O =
Fla Edit Sketch Tools Help

// put your main code here, to run repeatedly:
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3. Click "File" -> "Preferences"” on the menu bar to pop up the

preference setting interface.

'ﬂ sketch mardla | Arduine 1.8.19 = o =
E-:I-'. Sketch Tools Help
Maw Ciell &Py
Open... Cirlla
Open Recent
Sketchbook
Examples
Close Cirl o'W E 1 re, L
Sarve Cords5
Save Ak Cirle Shift+5
Page Setup  Cirl+ Shikt+ P
Primt CirisP
I m*:ml-;jz. code here, CLr =41 1
Chust Ctrds 0

Maapbeoy i Pige, 260 (na FEL 129 Mz, Smsl {-On) istandand) Disabisd, Onabind, Mone. Fics S0E an COLO0

4. Click the icon on the far right of the Additional Boards Manager
URLscolumn,enter https://github.com/earlephilhower/arduino-p
ico/releases/download/global/package_rp2040_index.json in
the pop-up window, and add RP2040 Arduino IDE development
board URLs.

oe]

P R H
Skatcaboak Lecutaen
4 Decaminti e dmias Brewas

::I Addiioral Boards Maragsr URLs x
.)'.

Ediccr Junguay T e s

Ehiter fami o

Burer aidicional Blx cme for sash ver
Enrarfacs pral

= I: fardulro-ploc/ releases/doweload/ global/package_sp2 040 index. ::-\:p.'slH
Thems

Shon verhees |

Compalar warnd et
«

Cloicpley 1§

i3 Clack for =

A Vari iy ead

B Chwih £

o Cuxcal

1% 41
w
Kddivi anal Besrds Banngar Wils- | coms'onr] ophi Dhowsrdur dui nompi eorel ewsesdbonnd sad/gl sbal fpackags_rp2ed_indes. jeen
TR il "uhar i w13 ik B e £l

ard JTAG. Dnalied, Dosbeed, Diabiel, USATS | Hardman COG, FPuge SFF 308 He 0T A WE S9FF 5L 280 GF 0, 62100
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5. Click "Tools" -> "Board.:..." -> "Boards Manager..." in the menu

bar to enter the Boards Manager interface.

Q sketch_mardla | Arduno 1.8.19

Fle Edd Sketch Tool Help

Auto Fosmat CrlaT
Archive Skeich

Fix Emcoading & Reload

1 Marsge Libranies Cirl « Shifis]
i Serial Monitos Civl & Shifys M
!
. L Serial Plotier Carl + Shift+1

WIFE0T 7 WiFININA Firrreare Updater

Board: *Arduine Lino®™ 1 Boands Manager...
i Ardisng AVE Boards
Get Board info ESPLI2 Arduno

Ratph P P arda2 .00}
Programmen "AVEISP mkil® 5 '.\pl.-!'.rr?'. :A J-CI..‘JJ.H.? g =

Burmn Bootosder

6. Enter "RP2040" in the search box, select "Raspberry Pi

Pico/RP2040" and install the development environment.

It should be noted here that when selecting the development
environment version, do not choose the latest one. It is

recommended to choose version 2.6.0.

ut

@ Boards Manager

_— ;

) Euspharry Fi Fice /EFIHD

! by Emrln F. Plilhowsr, LT version 2.7:0 THSTALLED

= Bomrds inchudud in thi packepe:

Ratpiteery % Proo, Rasotesrry Bf Pioe W, DuCB Habos, Adsbul Feathar SPD040, Adatiuf Feathar SP20AD SCORPID, Adalut
Huyhibey RPE040, Adsfrus T Py RP2040, Adedru STEMMA Frisnd RPZ040, Adsfrul Trinksy REI040 QT, Adafrut MacroPsd
RP2040, Adwfruit WB3040, Arduing Hena RPZ040 Connact, BrdgsTek IDMZ040:74, Cyptron Msker Hano RP2040, Cytran Maksr B
EP2040, DxtanossTs PcosDK. Defuilab FyScard2040Com, 0Ffobot Bastls AF2040. BactronicCats HunberCss HFC RE2040,
Extrametlactrorics §C20410, iLaks Challangar 2040 LYE. iLibs Chalanper 2040 LoRa. iLabs Chaflanger 2040 SubObe. iLabs
Chaplbpsagay DG WP, Labe Onglbesgay D04 Wik BLE. iLsbs Challenger HE 2040 WL iLals Chatlenge 2040 SOORTC, iLabs
Chalbesgar T040 MRC, iLase RPICOT, Mekopars Coolie APFOH0, Malapars Shake RPI0AD, nullits Bt-C PRI, Mmanon
FGAZDA0, Scider Purty REZ040 Stamp, SparkFun ProMicro REZ0MC, SparkFun Thing Flus RPZ040, ubssy APIC40 Deski, Ssesd
KE&D MP2040, WOC-ORD YO MP2040, Viyslab Miny RPZ040, Weneshare RAZ040 Zerc. Warsshars BPZ040 One, Warsstars
AF3Ga0 Blua AME, Waermhare REIG Flus LEMB, Weveahare AEI40 LD 056, Wavashars RE2040 LCD 138, WiE-ak

W1 00E-EVE-Hen. WIZnet WieR360-EvB-Pioo, Wlknel WISH0-EvB-Ten, Gerera BRI

Horg Infg

Ealaet veratem = n [piwts Fumzeu

“THETRECATEN — Flamse tmutall standalens puckages] hrduine Beed 05 Brards

b arvdusiens U OESCETE
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7. After the environment is successfully installed, if you find

"Rasperry Pi RP2040 Boards" in

the Arduino IDE development

board management, it means that the environment is successfully

©) skotch marD8a | Arduine 1210
File Edi Sketch Tasl Heip

Manage Libraries. Cirl+5hifc+
Serisl Mosibar Ctrl e Shifr et
Sarial Flotier CarleShitt+L

{H W07 [ WIRNINA Firmmare Updates

Board: *Ascuino Uno®

Gt Bowrd Info

Progremmer: "AVRISE mkll"

- ] b |
Y -0 Buto Format CtlsT
- e Archive Sketch
Ehich marlif i Enceding & Raload

Baomrd s Manager..

Ardhang ANR Boards ¥
drching Mibed 05 RPXME Boards &
ESP32 Arduing

EEPERSS Beards [3.0.3%

fium Bootivader |-

Ranpberry P BP0 Boarde[2.7.3) II

Software Settings

1. For the first use, you need to set

up and select the correct

development board. Click "Tools" -> "Board.:..." -> "Rasperry Pi
RP2040 Boards" -> "Rasperry Pi Pico" in the menu bar, as shown

in the figure below:

& EFizDespSeeplinpley | Ardued 18,15
Rle Ede Shexch Tonk Help

= [u] .
B Fanmal ool T P
—d
Archew Sieich =
JI0mrR e Fin Eftordirg & Reload el
"

Manags Liseariea. Cirl+ Shifee

Sarinl Wicritor Chol o Sl Bl
Serial Plotier Ctrt+ Shift <L
=113
— W WFPENS Firmsee Lipdshe:
= ESE Bosed “Ardune Lng® 1 Bcards Wiarsser_ Rapbersy B Puo
E3E t Lrdeinn LR Boaids Ampherny 5 P W
E it Bowrd info Arduing Mied (1% APASST Boards DB Bl
3 B . Adufruit Featar SP2040
lod it prggramee “ANRIER mikdl® EEPIZ Ardine: R
ELDEIeE Boarda (151 Adufruit Feother BPZ040 SCORFIO
L Burn Boofosder
Easplesiiy B RFA0R0 Boaeded T30 o Adafrui Hegliiey AP0
Adufrud OT Py RP20a]
- R PR, dis adufruit STIMMA Friend RF2080
lod. inie ) s ERERRDinic THIEHS 3 . &
afrud Trinkey AP0 OT
Lot ITFT WHITEl:
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2. Connect the Lora RA-08H Development Board to the computer

via a TYPE-C USB cable. When the development board is
connected to the computer for the first time, a "RPI-RP2" USB
virtual U disk will appear.

! RPI-RP2 (1}

3. Here you need to burn a sample code in the opened Arduino IDE
to convert the "RPI-RP2" USB virtual U disk into a "COM port". The
sample code path is shown in the figure below:

B sheth_marDa | Ardure 18 = = v
b Edi Shewh Ll
e e?
.
Crpen Reoest 1
sieetchbank o
Exampleu j
Cloas wriew E e
Sarew Dwlat . Busicn: I AnalogResdiemsl
Sww Ge o 02 Dol Barchtiskmam
St dralng Bk
iz 5 B Comesuric aion DighaResdiers
s oeE o8, Lomiral Fads
Peeferenoes  Dwls o b dog¥ekage
: o Diplay
o 0B Etrirga
ELLEE
0 S terdi Bamici
M.dudulealse
At Cirauit Flapgrow nd
Beidge
Faplara
Etherrest
nnnnnnn
GEAd

The code after_op_ehing is as follows:

& Blink | Arduino 1.8.19 = g "

Fla Edmt Sketch Tools Help

{ [IN )
¥

() {

{ [1 )

v (1000) ;
vy (1000) ; / wait for a second

I
£
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4. Click the download icon at the bottom of the menu bar to burn
the code to the Lora RA-08H Development Board. After the code is
burned successfully, COMXX (Raspberry Pi Pico) will be displayed
in "Tools" -> "Port". Now you can program Lora RA-08H
Development Board with Arduino IDE!

Sample Program

Example 1 - Switch Light
1.1 Connect the Crowtail-LED and Crowtail-Button to the D3 port
and D2 port of the Lora RA-08H Node board respectively.

e T : ;
1.2 Open the "Switch Light.ino" sample program in the Arduino

IDE, and then click the upload program icon to upload the program
to the development board.

void setup() {
pinMode(2, INPUT_PULLUP);
pinMode(3, OUTPUT);

void loop() {

11
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if (digitalRead(2) == HIGHX
digitalWrite(3, HIGH);
¥
else{
digitalWrite(3, LOW);
¥
}

1.3 After the program is successfully uploaded, press the button,
the led will light up; release it to turn off.

Example 2 - OLED Display

2.1 Connect the Crowtail OLED module and Crowtail linear
potentiometer to the Crowtail 12C port and AO port of the Lora
RA-08H node board respectively.

2.2 Open the "OLED.ino" sample program in the Arduino IDE, and
then click the upload program icon to upload the program to the
development board.

12

D SHENZHEN YIKENUO TECH DEVE CO.,LTD
& E’_ ECR ()W @Copyright Belongs To Elecrow



@’ELECROW PRODUCT SPECIFICATION

S

#include "hardware/adc.h”

#include <U8x8lib.h>

#include <Wire.h>

int val;

UBX8_SSD1306_128X64_NONAME_HW_I2C u8x8(/* reset=+/ USX8_PIN_NONE);

void setup() {
u8x8.begin();
u8x8.setFont(u8x8_font_chroma48medium8_r);//Small Font 16 Characters
u8x8.nolnverse();//Normal
u8x8.clear();
u8x8.setCursor(5,2);
u8x8.print("Lora DEV");
u8x8.setCursor(1,4);
u8x8.print("VALUE =");

}

void loop() {
int sensorValue = analogRead(A0);
delay(500);
u8x8.setCursor(9,4);
u8x8.print(" "),
u8x8.setCursor(9,4);
u8x8.print(sensorValue);

delay(100);

2.3 After the upload is successful, when you slide the handle of the
linear potentiometer, the OLED displays the current analog value in
real time.

Example 3 - Ultrasonic Ranging
3.1 Connect the Crowtail Ultrasonic Sensor to the
Crowtail UART port of the Lora RA-08H node board.

13
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3.2 Open the "Ultrasonic_ranging.ino” sample program in the
Arduino IDE, and then click the upload program icon to upload the
program to the development board.

const int TrigPin = 9;

const int EchoPin = 8;

float cm;

void setup()

{
Serial.begin(9600);
pinMode(TrigPin, OUTPUT);
pinMode(EchoPin, INPUT);

}
void loop()

{
digitalWrite(TrigPin, LOW);
delayMicroseconds(2);
digitalWrite(TrigPin, HIGH);
delayMicroseconds(10);
digitalWrite(TrigPin, LOW);

14
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cm = pulseln(EchoPin, HIGH) / 58.0;
cm = (int(cm * 100.0)) / 100.0;
Serial.print("Distance:");
Serial.print(cm);

Serial.print("cm™);

Serial.printIn();

delay(1000);

}

3.3 After the upload is successful, open the serial monitor to check

the serial port printing.

& come - ]
Samad

Distance:34.12cm
Distance: 4. 12cm
Distance:34d.53cm
Distance:3.l3cm

Distance:3.1%m

Distance:34.53cm
Distance: 3€, 58cm
Distance: b.54cm

Distance:5.61cm

Distance:35.25cm
Distance: 36. 12cm
Distance:34.79cm
Distance:37.87cm
Distance:I8.32cm

Distancs:37.44cm

Flastuserall [ 5her simasromp Feline w00 haed v Cleer sery i

Example 4 - Communication between RP2040 and RA-08H
4.1 Open the "RA_08H.ino" sample program in the Arduino IDE,
and then click the upload program icon to upload the program to
the development board.

void setup() {
// put your setup code here, to run once:
Serial.begin(9600);
Seriall.setRX(1);
Seriall.setTX(0);
Seriall.begin(9600);

SHENZHEN YIKENUO TECH DEVE CO.,LTD
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}
void loop() {

if (Serial.available())

{

Seriall.write(Serial.read());

}

if (Seriall.available())
{

Serial.write(Seriall.read());

}
}

4.2 After the program is successfully uploaded, open the serial
monitor and send the AT command "AT+CGSN?" to RA_08H.

© comso - o
! ireccerd Fird

EA dateaersdl [dkes timsas - Beelimm w | B e = Clew macput

4.3 After sending the command, if the monitor can display the
returned "+CGSN=85521C0A02243201 OK" (the value returned by
different RA-O8H firmware is different), it proves that you can send
AT commands through the Arduino IDE to control and set the

RA 08H module.

16
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Example 5 - Ra-08 transparent transmission application
5.1Connect the leads according to the diagram.

17
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5.2First prepare the transparent firmware, and use the firmware

download tool to download the firmware.

After connecting the wires according to the above instructions,
unplug the RST pin on the module, open the firmware burning tool,
select the firmware to be burned, click "Erase All", clear the original
firmware in the module, and erase After success, click "Start" to
burn the new firmware.

B Tremo Programmer — X
F].BE].'L . —
Serial Setting 1
Fort CoMi0 v
Baudrate 921600 v
Dowrdoad Files 2
@m ... ||@ |0x0s000000
] e |
O e[ ]
O e[ ]
O] e[ ]
m e[ ]
Ilawnloag' 3
Start Erasze A1l
0%
IDLE

18
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5.3Download the program for the two modules separately to realize

the transparent transmission function.

asetup{) {
put your setup code here, to run once:
Berial.begin (9600} ;

Sariall . setRX (1)
Seriall.=aetTX({0):
Seriall.begin {9600} ;

}
roid el |
if (Sarial.ava ible ()
{
Seriasll L ({Barial [§ ]
}
if [(Seriall.availabBble())
{
Serial.write (Seriall.read());
}
}

memrnrmmwmwuﬂm L T i s T W R e e o S e B e i A
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