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Purpose of the Document 

The purpose of this document is to explain the technical specifications and manual for using 
the LTE Cat 4/Cat 1 USB modem. 

 

Document History 
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A 5G HUB 08.12.2020 Initial Document 
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1 Package contents: 
 

1.1 LTE Cat. 4 USB Modem Package: 
• USB modem with LTE & Diversity & GNSS antenna connectors. 
• USB modem comes with either one of the following modem modules: 

o EG95NA: Cat 4 for North America 
o EG95EX: Cat 4 for Europe, Middle East, and Africa 
o EG91NAX: Cat 1 for North America 

1.2 Download 
 
Arduino software can be downloaded from the following website: 
5G-NB-IoT/KitSketches at master · 5ghub/5G-NB-IoT (github.com) 
 
To use the board with Arduino IDE and starts running Arduino projects and sketches, install the 
following software: 
 
Install Arduino IDE for Windows from the following web site 
https://www.arduino.cc/en/Main/Software 
 
Download and Install LTE&GNSS modem driver for Windows OS: 
https://github.com/5ghub/5G-NB-IoT/tree/master/Driver 
 
Download and Install QNavigator and QCOM tools for Quectel BG95 here: 
https://github.com/5ghub/5G-NB-IoT/tree/master/Tools 
 
Download and install Arduino library (5G-NB-IoT_Arduino.zip) here: 
https://github.com/5ghub/5G-NB-IoT 
 
All the following software can be installed from the GitHub location here: 
https://github.com/5ghub/5G-NB-IoT 
 
LTE cellular connectivity on Windows OS 
 
  

https://5ghub.us/
https://github.com/5ghub/5G-NB-IoT/tree/master/KitSketches
https://www.arduino.cc/en/Main/Software
https://github.com/5ghub/5G-NB-IoT/tree/master/Driver
https://github.com/5ghub/5G-NB-IoT/tree/master/Tools
https://github.com/5ghub/5G-NB-IoT
https://github.com/5ghub/5G-NB-IoT
https://5ghub.us/wp-content/uploads/2021/02/LTE-cellular-connectivity-on-Windows-OS.pdf
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2 General Description 
2.1 Overview 
The LTE Cat 4 USB modem is a cellular and GPS modem in a USB stick form factor. The USB modem has 
UFL connectors for LTE & Diversity & GNSS antennas.  The board is a powerful board that features a 
microcontroller and wireless modem. The microcontroller is an Atmel’s SAMD21G18A MCU which 
features a 32-bit ARM Cortex® M0+ core. The wireless modem is EG9x which is an embedded LTE Cat 4 or 
LTE Cat 1 wireless communication module. EG9x wireless modem provides a maximum data rate of 
150Mbps downlink and 50 Mbps uplink for Cat 4 and 10 Mbps downlink and 5 Mbps uplink for Cat 1. It 
provides data connectivity on LTE-FDD/HSPA/WCDMA networks. It also provides GNSS to meet 
customers’ specific application demands. 

The USB modem provides rich sets of Internet protocols, industry-standard interfaces 
(USB/UART/I2C/Status Indicator) and abundant functionalities. The board offers a high integration level 
and enables integrators and developers to easily design their applications and take advantage of the board 
low power consumption, many functionalities, and USB drivers for Windows 7/8/8.1/10, Linux and 
Android. 

The USB modem is a rich hardware board that can be used for the 4G LTE wireless technology and enables 
a variety of smart applications for devices.  It enables many applications such as wireless POS, smart 
metering, tracking, smart transportation, smart buildings, smart city, and smart homes. 

The board is also compatible with Arduino and Arduino software (IDE). Arduino sketches and examples 
are provided with the kit and additional sketches can be developed and uploaded to the board. 

2.2 Key Features 
• Microchip SAMD21G18 ARM Cortex® M0+ MCU 
• Quectel EG95NA (Cat 4) or EG95EX (Cat 4) or EG91NAX (Cat 1) module 
• Supports LTE/HSPA/WCDMA  
• Supports GPS, GLONASS, BeiDou, Galileo, QZSS 
• LTE & Diversity & GNSS UFL antenna connector 
• Supports receiver diversity (MIMO 2x2) 
• Nano USIM card slot 
• Supports the protocols TCP/UDP/PPP/ SSL/ TLS/ FTP(S)/ HTTP(S)/ NITZ/ PING/ MQTT 
• Supports SMS 
• Supports AT commands  
• Compact board size of 65.1 mm x 32mm  
• Window, Linux, Android software drivers 
• Arduino IDE Compatible 
• Ready for smart applications and development (smart home, smart city, smart transportation, 

smart metering, smart farming, smart waste management, asset tracking, location, navigation, 
mapping, and timing applications). Application such as Gas Detector, Soil PH Tester, Optical 
Sensor, Machinery Alarm System, Irrigation Controller, Elevator, Asset Tracking Electronics, 
Person/Pet Tracking, Water/Gas Metering, Smart Parking System, Fire Hydrant, Smoke Alarm, 
Trash Bin, Street Lighting 

https://5ghub.us/
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• The board can be powered via the USB connector 
• Each of the 14 general purpose I/O pins on the board can be used for digital input or 

digital output using pinMode(), digitalWrite(), and digitalRead() functions. Pins used 
for PWM can be using analogWrite() function. All pins operate at 3.3 volts. Each pin can 
source or sink a maximum of 10 mA and has an internal pull-up resistor (disconnected 
by default) of 20-60 K ohm. 

2.3 RF Bands: 
 

• EG95NA:  North America 
o LTE-FD: B2/B4/B5/B12/B13 
o WCDMA: B2/B4/B5 
o GSM/EDGE: - 

• EG95EX: Europe, Middle East, Africa 
o LTE-FD: B1/B3/B7/B8/B20/B28 
o WCDMA: B1/B8 
o GSM/EDGE: B3/B8 

• EG91NAX: North America 
o LTE-FD: B2/B4/B5/B12/B13/B25/B26 
o WCDMA: B2/B4/B5 
o GSM/EDGE: - 

  

https://5ghub.us/
https://www.arduino.cc/en/Reference/PinMode
https://www.arduino.cc/en/Reference/DigitalWrite
https://www.arduino.cc/en/Reference/DigitalRead
https://www.arduino.cc/en/Reference/AnalogWrite
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2.4 Overview Diagrams 
 

 

Figure 1. USB Modem Overview Diagram (EG95NA/EG95EX/EG91NAX)– Top View 

 

 

Figure 2. USB Modem Overview Diagram (EG95NA/EG95EX/EG91NAX)– Bottom View 

  

https://5ghub.us/
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2.5 Physical Characteristics 
The width and length of the USB modem is 32 mm (width) by 65 mm (length).  The board have two 
screw holes in each corner that allows the board to be attached to a surface or case.  

 

Figure 3. Physical Characteristics. 
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2.6 Peripherals – Pin out 

 

Figure 4. USB Modem Top Side (EG9x) 

 

https://5ghub.us/
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Figure 5. USB Modem Bottom Side  

https://5ghub.us/
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2.7 Hardware Specification 
 

Technical Specification 
Microcontroller (MCU) Atmel ATSAMD21G18, 32-Bit ARM Cortex 

M0+ 
Clock Speed 48 MHz 
Flash Memory 256 KB 
SRAM 32 KB 
NB-IoT Module Quectel EG95NA/EG95EX/EG91NAX 
Dimension 32 mm (width) by 65 mm (length) 
Weight 22 grams 
Power Supply  USB (5V) 
LED LED1, LED2, PWR LED, Status LED, Netlight LED 
Interfacing Logic Voltage Level (Operating 
Voltage) 3.3V 

Voltage output 5V, 3.3V 
RESET buttons Not Mounted 
User-defined Button Not Mounted 

USB Switch 1 switch to connect to MCU directly or EG9x 
directly 

General-purpose digital I/O Pins 14 (A0-A5, PA6, PA7, SS, MOSI, MISO, SCK, SDA, 
SCL) 

GPIO 2 connected to EG95NA/EG95EX/EG91NAX 
ADC 2 connected to EG95NA/EG95EX/EG91NAX 
USB 1 
I2C 1 
SPI 1 
UART 2 
ADC pins 6 (8/10/12-bit ADC channels) 
DAC pin 1 (10-bit DAC) 
External interrupts 14 (All general-purpose PINs) 
PWM pin 6 
DC Current per I/O Pin 10 mA 
JTAG Debug Cortex Debug Connector (Single Wire Debug) 
USIM Nano 
GNSS GPS, GLONASS, BeiDou/Compass, Galileo, QZSS 
Antenna 1 main, 1 Diversity, and 1 GNSS 

Band LTE-FDD: B2/B4/B5/B12/B13 
HSPA/WCDMA: B2/B4/B5 

Certification GCF/ FCC/ PTCRB/ IC 

Mobile Operator Certification Verizon/AT&T/T-Mobi le/Telus/U.S. 
Cellular/Rogers/Telus 

Notes: 

- UART can be programmed through any of general-purpose pins. 
- SPI can be programmed through any of general-purpose pins. 

https://5ghub.us/
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2.8 PIN Description 
 

PIN DIRECTION Description 
USB Connector I The USB modem is powered from the USB port (3.8V-5V) 

LED1 (USER) O LED which can be controlled from MCU (D25). When the pin is 
HIGH value, the LED is on, when the pin is LOW, it is off 

LED2 (USER) O LED which can be controlled from MCU (D26). When the pin is 
HIGH value, the LED is on, when the pin is LOW, it is off 

LED (NET) O Indicate the EG9x operation status 
LED (STAT) O Indicate the EG9x network activity status 
MCU RESET 
button I Not mounted 

EG95 RESET 
button I Not mounted 

User Button I Not mounted 
USB Switch I 1 switch to connect to MCU directly or EG95 directly 

IOREF O 

Provides the voltage reference with which the MCU operates. A 
device can read the IOREF pin voltage and select the appropriate 
power source or enable voltage translators on the outputs for 
working with the 5V or 3.3V 

3.3V O 
3.3V generated by the on-board regulator. Maximum current 
drawn is 3A. The regulator also provides power to the MCU and 
EG9x 

5V O 5V generated from the board. The board is supplied with power 
from USB connector (typical 5V) 

GND  Ground 
A0 IO Six analog inputs which can provide up to 12 bits of resolution 

(i.e. 4096 different values). By default, each input measures 
from ground to 3.3 volts, though is it possible to change the 
upper end of their range using the AREF pin 
A0 can also be used as a DAC output and provides a 10 bit 
voltage output with analogWrite() function 
Analog pins can be used as GPIOs 

A1 IO 
A2 IO 
A3 IO 
A4 IO 

A5 IO 

SCL IO I2C. The SCL (clock line). Can be used as GPIO 
SDA IO I2C. The SDA (data line). Can be used as GPIO 

AREFA I Input reference voltage for the analog inputs used for either he 
ADC or the DAC 

SCK IO SPI Interface. Can be used as GPIO 
MISO IO SPI Interface. Can be used as GPIO 
MOSI IO SPI Interface. Can be used as GPIO 
SS IO SPI Interface. Can be used as GPIO 
TX/TX3 IO GPIO or UART 
RX/RX3 IO GPIO or UART 
PA21/PA28 IO GPIO 
Cortex Debug 
Connector IO Using Single Wire Debug to burn bootloader and debug the 

board 

https://5ghub.us/
https://www.arduino.cc/en/Reference/AnalogWrite


 

13 USB Modem Rev 1.1                            Copyright © 5GHUB.US 

ADC0 I Connected to EG95. General purpose analogue to digital converter 
ADC1 I Connected to EG95. General purpose analogue to digital converter 
GPIO26 IO Connected to EG95. General purpose IO 
GPIO64 IO Connected to EG95. General purpose IO 
USIM I  Used to insert a Nano USIM. Connected to EG95 

USB Boot I Connected to EG9x. Force the EG9x to enter emergency download 
mode 

 

Precaution 

The USB modem runs at 3.3V. The maximum voltage that the I/O pins can tolerate i s 3.3V. 
Applying voltages higher than 3.3V to any I/O pin could damage the board  

 

2.9 EG95NA/EG95EX/EG91NAX chipset 
All functionality of the EG9x module shall be implemented excluding the following features. That is, the 
following features are not supported: 

- Audio, Earphone, and Codes are not supported. 
- PCM and I2C are not supported. 
- PSM_IND and AP_READY are not supported. 

 

2.10 Interface between SAM21D and EG95NA/EG95EX/EG91NAX 
The Microcontroller communicates with the EG95 through UART interfaces: 

- UART1: (PA12/PA13/PA14/PA15). Used for data transmission and AT command communication 
115200bps by default. The default frame format is 8N1 (8 data bits, no parity, 1 stop bit) Support 
RTS and CTS hardware flow control. 

- RI/DCD: (PB10/PB11). 
  

https://5ghub.us/
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3 Using the Board with Arduino IDE 
3.1 Installing the Software 
To use the board with Arduino IDE and starts running Arduino projects and sketches, install the 
following software: 

3.2 Setting Up the Board 
Gently move the switch S1 upward to put the board in Arduino mode as in the picture below. 

 

 

3.3 Setting Up Arduino IDE 
1- Insert the USB modem into the USB port of a computer. Launch Windows device manager and 

you shall see the Arduino board as below. 

 

https://5ghub.us/
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When the switch is positioned into the EG9x USB, Windows device manager shows the following 
ports 
 
 

 
 

2- Launch Arduino IDE and choose File->Preferences. In the Additional Boards Manager URLs, 
insert the following URL: 

https://raw.githubusercontent.com/5ghub/5G-NB-IoT/master/package_5G-NB-IoT_index.json 
 

https://5ghub.us/
https://raw.githubusercontent.com/5ghub/5G-NB-IoT/master/package_5G-NB-IoT_index.json
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3- In Arduino IDE, choose Tools->Board->Boards Manager, select and install “5G-NB-IoT SAMD 
Boards”. 

 
 
 

4- Choose “5G NB-IoT (Native USB Port)” 
  

https://5ghub.us/
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5- In the Arduino IDE, Choose Port and select the serial port where the board appears. 

 

6- In the Arduino IDE, Choose Sketch->Include Library->Add .Zip Library and select the file  
5G-NB-IoT_Arduino.zip  
 
You are now ready to start running Arduino sketches and projects. 
 

https://5ghub.us/


 

19 USB Modem Rev 1.1                            Copyright © 5GHUB.US 

 

3.4 Running Arduino Sketch 
1- Using Arduino IDE, open any Arduino sketch such as TurnOnAllPins.ino, choose Sketch->Upload 

and it will run on the USB modem. 

 

 
 
 

https://5ghub.us/
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